py-boto and LibreSSL

Having just recently performed an upgrade of OpenBSD 5.6 to OpenBSD 5.7, duplicity (my backup tool), stopped working for no apparent reason. At first, I thought it had something to do with the 0.6 branch becoming deprecated, but in the end I found out that this was just a warning message.